Redtail system availability update
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 13:50 PDT
Monitoring
Related to a widespread, third-party global outage, Redtail is continuously monitoring our systems and working to avoid any further disruptions to you. Currently, Redtail systems appear in good working order and we are actively working to resolve any remaining issues. Please be aware that certain functionality may be intermittently slow or unavailable as we troubleshoot throughout the day.
Posted Jul 19, 2024 - 07:07 PDT
This incident affected: Redtail CRM.