Redtail Email – Login Issues

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 05:46 PDT

Investigating

We are currently investigating an issue affecting Redtail Email login. Our team is working to restore functionality as quickly as possible.
Posted Jun 20, 2025 - 05:37 PDT
This incident affected: Redtail Email.