Redtail CRM – Email History Filter Issue Identified

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 09:53 PDT

Investigating

Our engineers have identified an issue affecting Redtail CRM Email History Filters and are actively investigating. We appreciate your patience as we work to resolve this.
Posted Jun 13, 2025 - 09:38 PDT
This incident affected: Redtail CRM.