New Imaging Maintenance Update
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Jun 29, 2023 - 08:27 PDT
Investigating
Users will be unable to login into the New Redtail Imaging. We are looking into an issue. We do sincerely apologize for any inconvenience this may cause to your daily operations.
Posted Jun 29, 2023 - 07:23 PDT
This incident affected: Redtail Imaging.