Redtail Email Services | Intermittent Inbound and Outbound Delivery Issues
Incident Report for Redtail Technology
Resolved
The issue impacting users ability to send and receive emails has been remediated and services have return to normal. We sincerely apologize for any negative impact to your day-to-day operations.
Posted Sep 05, 2024 - 10:13 PDT
Monitoring
Our engineers have identified an issue impacting some users when attempting to send and/or receive emails. They have implemented a fix to resolve the issues and are currently monitoring our systems to ensure flows normalize.
Posted Sep 05, 2024 - 09:31 PDT
This incident affected: Redtail Email.