Phone Service Provider reporting service disruption
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 09:23 PDT
Investigating
Our Phone Service Provider has reported a service disruption affecting phone engagements. Chat service is currently not impacted by this issue and is available! We apologize for any inconvenience and appreciate your patience while they work to resolve this issue.
Posted Apr 22, 2024 - 08:15 PDT
This incident affected: Client Services.