Some users are reporting issues logging in to Redtail Speak
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 08:44 PDT
Update
Redtail Engineers are aware of and actively investigation an issue in which users cannot log into the web based Speak 2.0. At this time, users can still log into the speak mobile app in the meantime to access and manage their accounts.
Posted Aug 04, 2022 - 06:49 PDT
Investigating
We are currently investigating this issue.
Posted Aug 04, 2022 - 06:42 PDT
This incident affected: Redtail Speak.