Redtail-Hosted Email – Issue Resolved

Incident Report for Redtail Technology

Resolved

The issue that was causing errors when sending emails through Redtail-hosted Email has been resolved. Users should now be able to send emails without disruption.

We appreciate your patience while our team worked to restore service. If you continue to experience any issues, please contact our support team for assistance.
Posted Sep 09, 2025 - 08:46 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 07:55 PDT

Investigating

Our engineers have identified the issue causing errors when sending emails through Redtail-hosted Email. We are working swiftly to restore full service.

We appreciate your patience as we work to resolve this.
Posted Sep 09, 2025 - 07:19 PDT
This incident affected: Redtail Email.