Partial Call Center VoIP Outage
Incident Report for Redtail Technology
Resolved
The incident has been resolved. Our VOIP Provider has confirmed all operations are back to normal.
Posted Aug 01, 2022 - 10:02 PDT
Investigating
Our callers may experience longer than normal hold times when attempting to contact us by phone. This is due to partial outages within our VoIP service, which is impacting our call centers. During this issue, callers may experience callback feature delays, continued ringing, inability for hold options, and dropped calls. We are working with their engineers to resolve the issues being experienced. Please remember that you can also email us at support@redtailtechnology.com or visit help.redtailtechnology.com for a plethora of knowledge sharing articles and videos. We do apologize for any inconvenience this may cause.
Posted Aug 01, 2022 - 08:38 PDT
This incident affected: Call Center.