Delay in Email Archive Display in Redtail CRM

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 06:20 PDT

Investigating

Certain Broker Dealer-affiliated email archive subscriptions are delayed in displaying in Redtail CRM, dating back to March 31, 2025. This data is being processed throughout the weekend and should be available early next week. Thank you for your patience as we work to resolve this.
Posted Apr 04, 2025 - 09:25 PDT
This incident affected: Redtail Email.