Redtail Email Services | Trouble Accessing Redtail Webmail
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Sep 25, 2024 - 15:19 PDT
Monitoring
Our engineers have isolated the issue impacting performance and accessibility and deployed a fix. We are currently monitoring things to ensure performance and access have normalized. We sincerely apologize for the duration of the incident and the negative impact it has caused. We are working to better understand the root cause and will implement some additional safeguards to prevent similar issues.
Posted Sep 25, 2024 - 14:39 PDT
Investigating
We are aware that some users continue to experience difficulties accessing webmail.redtailtechnology.com. Our team is actively working to resolve the issue as quickly as possible. We appreciate your patience and will provide updates as more information becomes available.
Posted Sep 25, 2024 - 11:23 PDT
Monitoring
Our engineers have implemented a fix to restore access to Redtail Webmail. This fix included a change to DNS which may require users to flush their browser cache and/or DNS cache to allow it to see them. Here some some help links to assist with users with those steps:
https://support.redtailtechnology.com/s/article/How-to-Flush-DNS-on-a-Windows-PC
https://support.redtailtechnology.com/s/article/How-to-Flush-DNS-on-a-MAC
https://support.redtailtechnology.com/s/article/Clear-Firefox-cache-and-Delete-cookies-from-Firefox

We are monitoring to ensure all services return to normal function. Some users may experience some latency due to the volume of traffic post issue. We sincerely apologize
Posted Sep 25, 2024 - 08:41 PDT
Update
We are continuing to investigate this issue.
Posted Sep 25, 2024 - 07:54 PDT
Investigating
We're currently experiencing a service disruption with Redtail Webmail. Our team is working diligently to resolve the issue as quickly as possible. Please check back for updates.
Posted Sep 25, 2024 - 05:52 PDT
This incident affected: Redtail Email.