Intermittent Connection Issues – Phone and Live Chat

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 09:15 PDT

Investigating

Redtail is currently experiencing phone and live chat issues due to a disruption with our provider.

In the meantime, please contact us at support@redtailtechnology.com. We will provide an update as soon as these systems are back online.

Thank you for your patience.
Posted Jul 15, 2025 - 08:18 PDT
This incident affected: Client Services.