Redtail Email Services | Delayed Inbound Email
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 06:38 PDT
Monitoring
Some users have reported a continued issue with delayed incoming emails. At this time, some residual delays may be experienced as the system works through a high volume event following the previously resolved issue. We sincerely apologize for any negative impact to your day-to-day operations that may have resulted due to the identified issue.
Posted Apr 08, 2024 - 13:14 PDT
This incident affected: Redtail Email.