Intermittent Access Issues with Redtail Platforms

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 09:59 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 07:49 PST

Investigating

Redtail platforms are currently experiencing intermittent issues. Some clients may experience slowness or difficulty accessing their accounts. Our team is actively working to restore full connectivity as quickly as possible.

We apologize for the inconvenience and appreciate your patience as we work to resolve this issue.
Posted Nov 20, 2025 - 06:38 PST
This incident affected: Redtail API (REST), Redtail CRM, Redtail Imaging, Redtail Email, Retriever Cloud, Retriever for Tailwag, Client Services, Outbound Integrations, Inbound Integrations/SSO, Redtail Speak, Redtail CRM Mobile, and Suite Sync.