Redtail Hosted Email Services - Webmail Access Issue
Incident Report for Redtail Technology
Resolved
The issue has been resolved. Again, we sincerely apologize for any negative impacts this issue may have caused on your daily operations. Our engineers will work to dissect the data to better understand how to prevent similar issues going forward.
Posted Jun 27, 2024 - 07:43 PDT
Monitoring
Our engineers identified the issue and implemented a fix. We are currently monitoring to ensure expected behavior. We sincerely apologize for any impact this issue may be causing to your day-to-day operations.
Posted Jun 27, 2024 - 07:30 PDT
Investigating
We are investigating an issue where some users are experiencing access issues with Redtail Webmail.
Posted Jun 27, 2024 - 07:10 PDT
This incident affected: Redtail Email.