Some users are reporting issues accessing Redtail's Products
Incident Report for Redtail Technology
Resolved
The issue impacting access to Redtail Sites has been identified and resolved. We sincerely apologize for any negative impact you may have experienced to your day-to-day operations.
Posted Jun 23, 2022 - 07:01 PDT
Investigating
We are currently investigating this issue.
Posted Jun 23, 2022 - 06:34 PDT
This incident affected: Redtail API (REST), Redtail CRM, Redtail Imaging, Redtail Webmail, Retriever Cloud, Retriever for Tailwag, Outbound Integrations, and Inbound Integrations/SSO.