Inbound Email Delays and SSO Access Issues

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Jul 01, 2026 - 06:04 PDT

Monitoring

The issue impacting Redtail Hosted Email services has been mitigated, and inbound email delivery has been restored. Some email messages that were deferred during the outage may continue to arrive with delays as sending mail systems retry delivery.

We are actively monitoring the environment to ensure all queued messages are processed successfully and services remain stable.

We are also continuing to investigate an issue impacting Single Sign-On (SSO) access to hosted email accounts for some users. As a temporary workaround, affected users may access their hosted email directly using their email credentials instead of SSO. We will provide additional updates as work continues to fully restore all affected services.
Posted Jun 30, 2026 - 13:41 PDT

Investigating

We are currently investigating an issue affecting Redtail Hosted Email services that is causing inbound email messages to be deferred. As a result, some incoming emails may be delayed in reaching user mailboxes. We have also identified an issue impacting Single Sign-On (SSO) access to hosted email accounts for some users.

As a temporary workaround, affected users may be able to access their hosted email directly by logging in with their email credentials instead of using SSO. Our teams have identified an underlying network connectivity issue and are actively working with the service provider to restore normal operations. We will provide additional updates as more information becomes available.
Posted Jun 30, 2026 - 13:23 PDT
This incident affected: Redtail Email.