Redtail Hosted Email Services | Issues Authenticating and Sending/Receiving Email
Incident Report for Redtail Technology
Resolved
The issues impacting users earlier today have been remediated and services have return to normal. We sincerely apologize for any negative impact to your day-to-day operations.
Posted Jul 29, 2024 - 11:10 PDT
Update
Our engineers are working to flush deferred mail in the inbound mail queues. At this time, some mail is currently delayed and should drain and clear up over the next couple of hours.
Posted Jul 29, 2024 - 07:42 PDT
Monitoring
Our engineers have identified the issue and have implemented a fix to resolve the issues. Impacted users should start seeing services start to normalize.
Posted Jul 29, 2024 - 07:10 PDT
Investigating
Our engineers are aware of any issue impacting some users when attempting to access their mailbox along with sending and receiving emails.
Posted Jul 29, 2024 - 06:47 PDT
This incident affected: Redtail Email.