Call Center VoIP Outage
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 08:23 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2022 - 06:21 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 16, 2022 - 06:14 PST
Investigating
Our callers will experience longer than normal hold times when attempting to contact us by phone. This is due to an outage within our VoIP service, which is impacting our call centers. During this issue, callers will experience callback feature delays, continued ringing, inability for hold options, and dropped calls. We are working with their engineers to resolve the issues being experienced. Please remember that you can also email us at support@redtailtechnology.com or visit help.redtailtechnology.com for a plethora of knowledge sharing articles and videos. We do apologize for any inconvenience this may cause.
Posted Nov 16, 2022 - 05:21 PST
This incident affected: Client Services.