Redtail Support System Delays

Incident Report for Redtail Technology

Resolved

This incident has been resolved and Redtail is working through delayed requests with priority.
Posted Jun 27, 2025 - 08:58 PDT

Update

We are currently experiencing delays in receiving email communications to Redtail. For immediate support, please contact us via chat or by phone.
Posted Jun 26, 2025 - 10:05 PDT

Investigating

We are currently experiencing delays in receiving communications when using Redtail Support to create cases within our support portal. For immediate support, please contact us via chat or call.
Posted Jun 26, 2025 - 09:46 PDT
This incident affected: Client Services.