Redtail Hosted Email: Mail Client Connection Issues

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Sep 25, 2024 - 15:18 PDT

Investigating

We are currently investigating an issue affecting third-party mail clients, which may cause disruptions in sending and receiving emails. Our team is actively working to resolve this, and we will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Sep 25, 2024 - 10:57 PDT
This incident affected: Redtail Email.