Redtail Speak SMS Delivery
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Oct 02, 2023 - 06:59 PDT
Identified
We are aware of an issue causing SMS delivery to fail to AT&T and Verizon carriers. Our SMS vendor is actively working to resolve this issue as soon as possible.
Posted Sep 28, 2023 - 13:28 PDT
This incident affected: Redtail Speak.