Redtail CRM | Email History Not Loading
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 09:51 PDT
Monitoring
A fix has been implemented to resolve the issue with Email History not loading within Redtail CRM. We will monitor things for a bit to ensure everything is back to normal.
Posted Jun 04, 2024 - 07:57 PDT
Identified
Our engineers have identified the issue and are diligently working on implementing a fix. We greatly appreciate your patience and understanding while we work to resolve this issue. As with any service issue, we sincerely apologize for any negative impact this may create in your current daily operations.
Posted Jun 04, 2024 - 07:41 PDT
Investigating
We are currently investigating an issue impacting Email History with Redtail CRM. At this time, users that utilize the Email History Feature is currently showing as blank. Our engineers are working to identify the issue. We apologize for any negative impact this may create in your current daily operations.
Posted Jun 04, 2024 - 07:05 PDT
This incident affected: Redtail CRM.