Multi-Factor Authentication Texting Delays: Use Email for Faster Access
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Oct 25, 2024 - 13:38 PDT
Investigating
The third-party texting service used by both Orion and Redtail for multi-factor authentication is currently experiencing delays. For quicker access, please select the "Email" option to receive your multi-factor authentication code.

Thank you for your understanding.
Posted Oct 24, 2024 - 10:50 PDT
This incident affected: Redtail CRM.