Privacy Error When Using Bookmarked URL for Redtail CRM
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 14:33 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 25, 2024 - 13:50 PDT
Investigating
We are aware that some users are impacted by a privacy error message when accessing saved URLs or bookmarks for the Redtail CRM. Please log on directly to the CRM at this time via crm.redtailtechnology.com.
Posted Jul 25, 2024 - 13:43 PDT
This incident affected: Redtail CRM.