Redtail CRM – Internal Error Issues

Incident Report for Redtail Technology

Resolved

Users seeing an error in the CRM can switch to Early Access as a workaround to resolve the issue and continue using the CRM without disruption.
Posted Jul 09, 2025 - 08:34 PDT

Investigating

We are currently investigating an issue affecting Redtail CRM. Our team is working to restore functionality as quickly as possible.
Posted Jul 09, 2025 - 07:27 PDT
This incident affected: Redtail CRM.