Redtail Hosted Email Services - Mail Client Access Issues
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 12:37 PDT
Monitoring
Our engineers have identified the issue had implemented a fix. We are monitoring services to ensure normal functionality has returned.
Posted Sep 09, 2024 - 07:29 PDT
Investigating
Some users may not be able to connect with mobile devices and mail clients at this time. A workaround is available to log in directly through webmail at this time while the issue is being investigated.
Posted Sep 09, 2024 - 06:32 PDT
This incident affected: Redtail Email.