Redtail Email Services: Trouble Accessing Redtail Webmail

Incident Report for Redtail Technology

Resolved

This incident has been resolved.
Posted Sep 26, 2024 - 07:58 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2024 - 07:05 PDT

Identified

Our engineers have identified the issue causing some users to experience difficulties accessing webmail.redtailtechnology.com and we are working swiftly to restore services. We appreciate your patience as we work to resolve this.
Posted Sep 26, 2024 - 06:52 PDT
This incident affected: Redtail Email.