Redtail Email Services | Delayed Inbound Email
Incident Report for Redtail Technology
Postmortem

Redtail’s Email Services Engineers have investigated the issue resulting in some Redtail Email Services users experiencing inbound delayed mail and/or receiving server generated Delayed Mail (will be retried) notices. The root cause was determined to be created when services failed on an internal mail flow component which caused mail to pool for a period of time resulting in the triggering of the delayed mail notices. Over time, the delayed mail notices caused some chain reaction mail loops from outside servers that were quickly filling up mail queues and impacting delivery times. We have performed an audit of all proactive and service monitoring along with accompanying alerts to help prevent a similar issue going forward. As part of a current project already underway, we are building all new infrastructure for Redtail’s Email Services and we will be looking at ways within this project’s scope to build in more resiliency for issues like these. Again, we sincerely apologize for any negative impact the issue may have created on your daily operations. Thank you for your continued support of Redtail and it’s services.

Posted Apr 10, 2024 - 07:30 PDT

Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 12:27 PDT
Update
Some residual delays still may be experienced as the system works through backlog of queued/deferred mail. Inbound delivery for new mail may be slowed a little as well due to the processing of deferred mail and peak traffic hours on a Monday. We sincerely apologize for any negative impact to your day-to-day operations that may have resulted due to the identified issue.
Posted Apr 08, 2024 - 09:03 PDT
Monitoring
Some users have reported an issue with delayed incoming emails. Our Engineers have investigated the reported issue and verified an issue with our email gateway that was quickly resolved. Once the our Engineers took the necessary corrective measures, mail started flowing as expected. Some residual delays may be experienced as the system works through backlog of queued mail. We sincerely apologize for any negative impact to your day-to-day operations that may have resulted due to the identified issue.
Posted Apr 08, 2024 - 05:35 PDT
This incident affected: Redtail Email.