Redtail Hosted Email Services | Domain Aliases Returning Bounced
Incident Report for Redtail Technology
Postmortem

Due to am inadvertent attribute change within our spam scanning configuration, emails to domain aliases were bounced back to the senders. Once the issue was reported and verified, our engineers quickly resolved the issue to correct the mail flow issues for domain aliases. We have implemented some additional processes and knowledge building to mitigate similar issues in the future.

Posted Jun 10, 2022 - 08:14 PDT

Resolved
For a period time between June 9th at 11:30AM PDT through June 10th at 10:00AM, emails sent to domain aliases were bounced back to the sender. We have taken the necessary steps to remediate the issue and all mail to domain aliases should now be delivered successfully. We sincerely apologize for any negative impact on your day-to-day operations this may have caused.
Posted Jun 10, 2022 - 07:00 PDT