Redtail Email Services | Intermittent Webmail Slowness
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 11:53 PDT
Identified
Some user may be experiencing some latency within Redtail Webmail. Our engineers have identified the issue, and implemented a fix and are actively monitoring the service resources. We apologize for any negative impacts this may have to your operations.
Posted Sep 06, 2024 - 09:27 PDT
This incident affected: Redtail Email.