Redtail Email – Inbound Message Delays

Incident Report for Redtail Technology

Resolved

We’ve resolved the earlier inbound message delays, and all systems are now operating normally.

Please note: Messages sent during the impacted window may still experience delays of up to a few hours as they are processed by the sending servers. No action is required at this time. We will continue to monitor the queue to ensure full delivery.
Thank you for your patience.
Posted Jun 10, 2025 - 08:43 PDT

Investigating

We are currently investigating delays in inbound messages for Redtail Email. Users may experience slower-than-usual delivery times. We’ll provide an update as soon as more information is available.
Posted Jun 10, 2025 - 08:07 PDT
This incident affected: Redtail Email.