Some users reporting issues with Redtail CRM
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted May 02, 2022 - 08:50 PDT
Investigating
Some users are reporting issues when attempting to login to Redtail CRM. Our engineers are working to identify the issue impacting those features.
Posted May 02, 2022 - 07:11 PDT
This incident affected: Redtail CRM.