Redtail Email Services | Delayed Inbound Email
Incident Report for Redtail Technology
Resolved
This issue is considered resolved. Thank you for your patience and understanding as we work though some of the issues with our service infrastructure improvements.
Posted Sep 24, 2024 - 16:24 PDT
Monitoring
Our Engineers have taken steps to mitigate the delays that were impacting inbound mail delivery. We are actively monitoring performance to ensure processing times have returned to normal. We apologize for any negative impact this may have created on your day-to-day operations.
Posted Sep 24, 2024 - 13:52 PDT
Investigating
Our engineers are currently investigating an issue with delayed inbound email. We are working to identify the issue and to swiftly restore delivery times. Thank you in advance for your patience as we work to resolve this.
Posted Sep 24, 2024 - 09:31 PDT
This incident affected: Redtail Email.