Redtail Hosted Email Services | Delivery Issues to some free email providers.
Incident Report for Redtail Technology
Resolved
The deliverability issues to some email providers has been resolved. We thank you for your patience and understanding as we worked to clear up the issue.
Posted Jul 23, 2024 - 18:53 PDT
Monitoring
We are beginning to see outbound emails to those impacted providers deliver successfully to their servers. We will continue to monitor.
Posted Jul 23, 2024 - 16:28 PDT
Identified
We are currently aware of an issue with some email provider (msn.com, live.com, hotmail.com, bellsouth.net) bouncing emails from Redtail IPs. Our engineers have reached out to the providers in an effort to try and determine the root cause and seek resolution.
Posted Jul 23, 2024 - 10:23 PDT
This incident affected: Redtail Email.