Redtail Email Services | Delivery Issues to Microsoft Hosted Mailboxes
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 06:44 PDT
Monitoring
At this time, we are seeing the successful delivery of mail between our servers and Microsoft's servers. We will be monitoring the exchange of mail to ensure the issue is fully resolved. We thank you for your patience and understanding as we work with Microsoft on a resolution.
Posted Jul 25, 2024 - 05:34 PDT
Investigating
We are currently aware of an issue impacting delivery to Microsoft hosted mailboxes and their free email accounts (live.com, msn.com, outlook.com, and hotmail.com) from Redtail IPs. Our engineers have reached out to Microsoft in an effort to try and determine the root cause and seek resolution.
Posted Jul 24, 2024 - 07:38 PDT
This incident affected: Redtail Email.