Redtail Email Issues
Incident Report for Redtail Technology
Resolved
This incident has been resolved. Again, we sincerely offer our apologies for any negative impact to your daily operations. We wholeheartedly appreciate your continued support of Redtail and our services.
Posted Apr 03, 2024 - 06:27 PDT
Monitoring
Our Engineers have implemented a fix to resolve the issue impacting users of Redtail's Hosted Email Services and are currently monitoring to ensure all service functionality returns to normal. We sincerely apologize for the issue and any impact to your day-to-day operations.
Posted Apr 03, 2024 - 06:12 PDT
Identified
Our Engineers have identified the root cause of the issue impacting Redtail's Hosted Email Services. They are currently working on a fix to correct the root cause. Thank you for your patience as we work to get your service back to normal and expected functionality.
Posted Apr 03, 2024 - 06:02 PDT
Investigating
We are aware of email issues and have identified the issue. We are working toward resolution and it should be resolved shortly.
Posted Apr 03, 2024 - 05:53 PDT
This incident affected: Redtail Email.