Users reporting issues with Redtail Email
Incident Report for Redtail Technology
Resolved
Our technicians have made the necessary hardware changes to correct the issue that was degrading the performance of Redtail's hosted email service. We do sincerely apologize for any negative impact the issue may caused to your day to day operations. Thank you for your patience and continued support.
Posted Oct 01, 2020 - 06:30 PDT
Monitoring
Our engineers are in the process of deploying a fix to improve the latency issues some may be experiencing. We do sincerely apologized for the prolonged issue.
Posted Sep 30, 2020 - 10:27 PDT
Identified
The issue has been identified. We are taking the necessary steps to correct the issue. Thank you in advance for your patience has we work through this issue.
Posted Sep 29, 2020 - 14:02 PDT
Investigating
Some Redtail Hosted Email Service subscribers may be experiencing issues with performance such as latency when sending emails and accessing their mailbox at this time. Our Troubleshooting Troubadours have investigating the issue.
Posted Sep 29, 2020 - 09:27 PDT
This incident affected: Redtail Email.