Some users reporting issues with Redtail Hosted Email Services
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Jan 10, 2022 - 12:12 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 10, 2022 - 12:07 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 10, 2022 - 12:07 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 10, 2022 - 11:58 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 10, 2022 - 11:58 PST
This incident affected: Redtail Webmail.