Users reporting issues with Redtail Email (INC-29)
Incident Report for Redtail Technology
Resolved
Listen. Do you hear it? That is the sweet melody of resolution. The ring of sensors turning green is a satisfying sound of success. We sincerely apologize for the issue and any negatively impact on your day. We will work to understand the root cause and proactively take steps to make any needed improvements. Take care of yourself. Wash those hands. 20 seconds.
Posted Apr 07, 2020 - 16:52 PDT
Update
Our Troubadours continue to work hard to create a magic melody of resolution. We appreciate your patience.
Posted Apr 07, 2020 - 16:33 PDT
Identified
Some Redtail Hosted Email Service subscribers may be experiencing issues accessing their mailbox at this time. Our Troubleshooting Troubadours have identified the issue and are currently penning a resolution.
Posted Apr 07, 2020 - 16:00 PDT
This incident affected: Redtail Email.