Intermittent Email Hosting Services Issue
Incident Report for Redtail Technology
Resolved
Rejoice! A calm falls over the land of Email as the issue afoot has been resolved. Our always ready System Defenders and their Boomsticks have saved the day thwarting the Tribbles of T-Error's hunger for virtual machines. Hugs for everyone!. On a serious note, we do apologize for the issue and any impact it may have had on your business operations as email plays a vital part of your success.
Posted Oct 28, 2015 - 15:34 PDT
Identified
Some users are experiencing an issue when attempting to accessing their mailbox and/or sending and receiving mail. We are aware of the issue and are working to restore all systems to operational status.
Posted Oct 28, 2015 - 14:39 PDT