Users reporting issues with Redtail Email
Incident Report for Redtail Technology
Resolved
Redtail's Hosted Email Services have returned to normal functionality for all users. We do apologize for any inconveniences and interruptions to your daily operations that you may have experienced as a result of the issue.
Posted Feb 07, 2020 - 08:49 PST
Investigating
Some users are reporting intermittent issues accessing Redtail Webmail or their mailbox within offline clients such as Outlook. We have unleashed the issue-sniffing tech hounds to track down the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations as email is a vital tool.
Posted Feb 07, 2020 - 07:26 PST
This incident affected: Redtail Webmail.