Users reporting issues with Redtail Email and Redtail CRM
Incident Report for Redtail Technology
Resolved
There was an issue with outside ISPs impacting a large number of user's bandwidth which resulted in latency and connectivity issues. We have monitored this for most of the day and all issues appear to have been resolved.
Posted Apr 21, 2020 - 20:42 PDT
Monitoring
We have identified this to be related to a major ISP upstream issue. We will continue to monitor Redtail's products in case these issues trickle downstream.
Posted Apr 21, 2020 - 14:01 PDT
Investigating
Some users are reporting slowness or an inability to login to Redtail CRM as well as Redtail Email. We have unleashed the issue-sniffing tech hounds to track down the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted Apr 21, 2020 - 08:15 PDT
This incident affected: Redtail CRM and Redtail Webmail.