CRM Slowness
Incident Report for Redtail Technology
Resolved
The performance issues have been resolved. Thank you for your patience.
Posted Apr 06, 2016 - 16:04 PDT
Identified
Some users are experiencing issues within the CRM related to performance. We're currently working to resolve the issues being reported. Thank you for your patience while we work to resolve this issue.
Posted Apr 06, 2016 - 14:15 PDT