Users reporting issues with Redtail Email
Incident Report for Redtail Technology
Resolved
Redtail's Hosted Email Services have returned to normal functionality for all users. We apologize for the issue. We do apologize for any inconveniences and interruptions to your daily operations that you may have experienced as a result of the issue
Posted 16 days ago. Sep 30, 2019 - 13:03 PDT
Identified
Users are reporting a Risk Warning when attempting to access webmail as well as offline client configurations utilizing SSL connections. We are aware of the issue and are working quickly to resolve. We do sincerely apologize for any inconvenience the issue may cause to your daily operations as email is a vital tool.
Posted 16 days ago. Sep 30, 2019 - 11:41 PDT
This incident affected: Redtail Webmail.