Users reporting intermittent issues within Redtail CRM (Tailwag Interface)
Incident Report for Redtail Technology
Resolved
All systems have returned to normal operation at this time. We do sincerely apologize for any inconvenience the issue may have caused to your daily operations.
Posted 27 days ago. Dec 26, 2017 - 10:40 PST
Investigating
Some users are reporting intermittent issues within Redtail CRM's Tailwag interface. We are troubleshooting now to determine a root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted 27 days ago. Dec 26, 2017 - 10:22 PST