Users reporting issues with Redtail Email
Incident Report for Redtail Technology
Resolved
Listen. Do you hear it? That is the sweet melody of resolution. The ring of sensors turning green is a satisfying sound of success. We sincerely apologize for the issue and any negatively impact on your day. We will work to understand the root cause and proactively take steps to make any needed improvements. Take care of yourself. Wash those hands. 20 seconds.
Posted Feb 11, 2021 - 07:31 PST
Investigating
Some Redtail Hosted Email Service subscribers may be experiencing issues accessing their mailbox at this time. Our Troubleshooting Troubadours have identified the issue and are currently penning a resolution.
Posted Feb 11, 2021 - 06:30 PST
This incident affected: Redtail Webmail.