Known Issues with Redtail CRM
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Mar 24, 2020 - 00:55 PDT
Investigating
Some users are reporting an inability to login to Redtail CRM. We have unleashed the issue-sniffing tech hounds to track down the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted Mar 23, 2020 - 23:52 PDT
This incident affected: Redtail CRM.