Users reporting issues with Redtail Email
Incident Report for Redtail Technology
Resolved
Redtail's Hosted Email Services have returned to normal functionality for all users. We apologize for the issue. We do apologize for any inconveniences and interruptions to your daily operations that you may have experienced as a result of the issue
Posted 16 days ago. Sep 30, 2019 - 07:44 PDT
Update
We are continuing to work on a fix for this issue.
Posted 16 days ago. Sep 30, 2019 - 05:29 PDT
Identified
Some users are reporting intermittent issues accessing Redtail Webmail or their mailbox within offline clients such as Outlook. We have unleashed the issue-sniffing tech hounds to track down the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations as email is a vital tool.
Posted 16 days ago. Sep 30, 2019 - 05:29 PDT
This incident affected: Redtail Webmail.