Some users reporting issues accessing Redtail CRM & Imaging.
Incident Report for Redtail Technology
Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 09:09 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2022 - 08:32 PST
Investigating
Some users are reporting issues when attempting to login to Redtail CRM and Imaging. Our engineers are currently looking into the issue and working to identify the root cause. We do sincerely apologize for any inconvenience the issue may cause to your daily operations.
Posted Jan 25, 2022 - 08:23 PST
This incident affected: Redtail CRM and Redtail Imaging.